Ошибки при выполнении действий, требующих взаимодействия с MS Visio (открытие диаграмм, построение отчетов и т.п.).

Вопрос:

При выполнении действий «Передать диаграмму в Visio», «Предварительный просмотр», «Печать», при построении отчетов, содержащих диаграммы, при автообновлении диаграмм, а также при других подобных действиях, использующих Microsoft Visio, возникают ошибки. Как от них избавиться?

Ответ:

Возможные причины:

  1. При запуске Microsoft Visio отдельно от Business Studio выдаются какие-либо окна с информацией об ошибках, необходимости пройти активацию или еще с какой-то другой информацией, требующие реакции пользователя.
  2. На компьютере могут быть установлены надстройки для Microsoft Visio, которые блокируют файл диаграммы.
  3. Ошибка может возникать из-за того, что Microsoft Visio пытается соединиться с Интернетом и не получает доступа.
  4. Были изменены параметры оргдиаграммы в базовых настройках Business Studio (для версий < 3.5).

Решение:

  1. Добиться, чтобы при запуске Microsoft Visio отдельно от Business Studio не выдавалось никаких окон, требующих реакции пользователя и программа сразу была готова к работе.
  2. Удалить надстройки Microsoft Visio.

    Для этого необходимо выйти из Business Studio, запустить MS Visio и следовать приведенным ниже инструкциям.

    Для Microsoft Visio 2003:
    Откройте меню «Tools/Macros/COM Add-Ins…», удалите надстройки. Откройте меню «Tools/Options», выберите вкладку «Security», опция «Enable COM Add-Ins» должна быть включена.

    Для Microsoft Visio 2007 (русская версия):
    Откройте меню «Сервис/Центр управления безопасностью…», выберите вкладку «Надстройки», удалите активные надстройки приложений. Опция «Отключить все надстройки приложений (возможно нарушение функциональности)» должна быть отключена (см. рисунок).
    to_org.jpg
    Для Microsoft Visio 2010 (русская версия):
    Откройте меню «Файл/Параметры», выберите вкладку «Надстройки», удалите активные надстройки приложений. В этом же окне выберите вкладку «Центр управления безопасностью» и нажмите кнопку «Параметры центра управления безопасностью…». В открывшемся окне выберите вкладку «Надстройки», опция «Отключить все надстройки приложений (возможно нарушение функциональности)» должна быть отключена.
    Закройте Microsoft Visio.

  3. Отключить опции обращения в Интернет в свойствах Visio.

    Для этого необходимо выйти из Business Studio, запустить MS Visio и следовать приведенным ниже инструкциям.

    Для Microsoft Visio 2003: Откройте меню «Tools/Options», выберите вкладку «General», кнопка «Service Options»; отключите все, что касается обращения в online (обновления и справка).

    Для Microsoft Visio 2007 (русская версия): Откройте меню «Сервис/Параметры…», выберите вкладку «Общие», нажмите кнопку «Параметры служб»; отключите все, что касается обращения в online. Откройте меню «Справка/Параметры конфиденциальности», также отключите все, что касается обращения в online (справка, обновления, параметры перевода, параметры справочных материалов).

    Для Microsoft Visio 2010 (русская версия): Откройте меню «Файл/Параметры», выберите вкладку «Центр управления безопасностью» и нажмите кнопку «Параметры центра управления безопасностью…». В открывшемся окне выберите вкладку «Параметры конфиденциальности»; отключите все, что касается обращения в online (справка, обновления, параметры перевода, параметры справочных материалов).
    Закройте Microsoft Visio.

  4. Изменить параметры оргдиаграммы в Настройках для всех пользователей Business Studio для формирования диаграммы с настройками по умолчанию.

    Для этого необходимо в Business Studio выполнить пункт главного меню «Сервис/Настройки для всех пользователей», в появившемся окне открыть параметр "Параметры оргдиаграммы", в окне параметров оргдиаграммы полностью удалить все строки списка «Поля оргдиаграммы» (диаграмма будет формироваться с параметрами по умолчанию) и сохранить настройки.
Актуальные новости, публикации и практики для бизнес-архитекторов и аналитиков
Driven by DokuWiki