Окно диаграммы

Окно диаграммы предназначено для создания и редактирования диаграмм единиц деятельности, организационных диаграмм, диаграмм стратегических карт и диаграмм Исикавы (Рис. 1).

Рисунок 1. Окно диаграммы


Окно диаграммы открывается двойным щелчком по названию объекта, для которого может быть построена диаграмма, в Навигаторе или щелчком по кнопке на панели инструментов Навигатора.

Практический совет

Навигатор и Окно диаграммы всегда одновременно открыты в Главном окне программы. Разделяющая их подвижная граница дает возможность изменять их размеры относительно друг друга. Если для работы с диаграммой требуется вся рабочая область Главного окна, то окно Навигатора можно свернуть, нажав на кнопку Скрывать автоматически в заголовке Навигатора.


Сверху расположена панель инструментов. Работа с инструментами происходит нажатием на кнопки панели. Слева расположена палитра элементов, набор фигур которой зависит от типа редактируемой диаграммы. Работа с элементами на палитре возможна нажатием их кнопок или переносом фигур на диаграмму. При нажатии на фигуру осуществляется добавление в центр текущей диаграммы (может использоваться для быстрого добавления сразу нескольких фигур). При нажатии на фигуру "Рамка" осуществляется добавление рамки на диаграмму и размещение ее по границам рабочей области диаграммы с учетом отступа рамки, заданного в Настройках пользователя в параметре Настройки диаграмм. При необходимости размеры рамки можно изменять. Для того чтобы разместить рамку по границам рабочей области диаграммы с учетом отступа рамки, можно воспользоваться пунктом контекстного меню рамки Центрировать рамку.

Описание назначения кнопок панели инструментов Окна диаграммы приведено в Таблице 1:

Кнопка Назначение
Свойства объекта (Ctrl+E). Открывает Окно свойств объекта, обозначенного данной фигурой диаграммы. В случае, если фигура принадлежит диаграмме, Окно свойств объекта открывается без возможности сохранения произведенных изменений, в отличие от того же окна, открываемого для объекта из Навигатора (см. Окно свойств объекта). Изменения свойств объектов, диаграммы сохраняются при сохранении всей диаграммы в целом.
Сохранение диаграммы (Ctrl+S). Сохраняется текущая диаграмма, то есть все её фигуры и сделанные в них изменения. При работе с диаграммами, изменения, которые в них делаются, сразу отражаются в дереве объектов (например, добавляется функция или действие). Несмотря на это, при отказе от сохранения изменений на диаграмме, в дереве все элементы также останутся без изменений (т.е. не будет добавлена новая функция или действие). Если во время редактирования диаграммы в дереве изменяются другие элементы, не имеющие отношения к текущей диаграмме, то эти элементы сохраняются сразу автоматически. При работе с другими типами диаграмм изменения и производимые с элементами действия (добавление фигур на диаграмму, создание связей между элементами) сохраняются в момент сохранения диаграммы. Если произведенные на диаграмме изменения не были сохранены, то при смене или закрытии диаграммы выдается запрос о подтверждении сохранения изменений при отключенной опции Автосохранение диаграмм в Настройках пользователя.
Обновить. Диаграмма загружается из базы данных. Несохраненные изменения будут утеряны.
Работа с текстовыми метками (Ctrl+Т, двойной щелчок средней кнопкой мыши). Состояние включено/выключено (кнопка нажата/отжата). Во включенном состоянии позволяет добавить на диаграмму произвольный текст, а также изменить надпись фигуры и положение надписи относительно фигуры. (Для управления с помощью мыши функция средней кнопки должна быть установлена в Middle Button в панели управления мышью Windows.)
Формат по образцу (Ctrl+Shift+P). Копирует формат выделенной фигуры. Подробнее см. Копирование формата фигуры диаграммы.
Предыдущая диаграмма. Осуществляется переход к предыдущей открытой диаграмме, сохраняется история перемещений до закрытия Окна диаграммы.
Следующая диаграмма. Осуществляется переход к следующей открытой диаграмме, сохраняется история перемещений до закрытия Окна диаграммы. Кнопка активируется, если был переход к предыдущей открытой диаграмме.
Управление масштабом диаграммы.
Масштаб по умолчанию. Если кнопка нажата - открытие диаграммы осуществляется в том масштабе, который выбран в выпадающем списке масштабов. Удобно для просмотра большого количества диаграмм. Если кнопка отжата - диаграммы открываются с сохраненным масштабом.
Таблица 1. Панель инструментов окна диаграммы

Описание назначения пунктов выпадающего меню кнопки Действия приведено в Таблице 2.

Пункт меню Назначение
Открыть диаграмму в MS Visio Открывает окно Microsoft Visio, в котором диаграмму можно сохранять, корректировать, распечатать, отправить по почте. Это однонаправленная операция: изменения, сделанные в Microsoft Visio, не переносятся в Business Studio.
Печать Открывает окно Печать для редактирования параметров вывода на печать.
Страница → Параметры страницы Открывает окно Параметры страницы для редактирования параметров страницы текущей диаграммы.
Страница → Изменить размеры по содержимому Для MS Visio 2010 и 2013. Установка флажка для пункта меню Изменить размер по содержимому изменяет размеры диаграммы так, чтобы она занимала все доступное пространство страницы (см. Изменение параметров страницы диаграммы).
Страница → Сетка Флажок отображает сетку на диаграмме.
Страница → Параметры сетки Открывает окно Линейка и сетка с настройками сетки страницы. Все фигуры на диаграмме, создаваемые автоматически, выровнены по сетке.
Страница → Разрывы страниц Включает отображение на диаграмме разрывов страниц. Это позволяет посмотреть, что будет напечатано на каждой странице документа.
Дополнительно → Панорама и масштаб Открывает панель Панорама и масштаб для масштабирования страницы с диаграммой в рабочей области Окна диаграммы.
Дополнительно → Масштаб Открывает окно с настройкой масштаба.
Дополнительно → Размер и положение Открывает панель Размер и положение, показывающую координаты выбранной фигуры. Удобно для точного позиционирования фигур.
Положение фигур → Выравнивание фигур (F8) Работает с двумя и более выделенными фигурами. В окне Выравнивание фигур выбирается вид выравнивания фигур.
Положение фигур → Распределение фигур Работает с тремя и более выделенными фигурами. В окне Распределение фигур выбирается вариант распределения фигур.
Положение фигур → Привязка фигур (Alt+F9) Открывает окно Привязать и приклеить с настройкой привязок. Здесь можно настроить способ "приклеивания" фигур друг к другу и выравнивания фигур по сетке.
Графические стили Работа со стилями диаграммы. Подробнее см. Стили диаграмм.
Таблица 2. Пункты выпадающего меню кнопки "Действия"

Палитра элементов окна диаграммы

Описание назначения кнопок палитры элементов Окна диаграммы приведено в Таблице 3.

Кнопка Назначение
Добавление сноски. Используется как дополнительный комментарий к объекту. Подробнее о текстовых метках на диаграммах см. Текстовые метки на диаграмме.
Создать рамку. На диаграмме создается рамка. Если она уже существует, никаких действий не произойдет. Рамка не используется на диаграммах в нотациях Cross-functional Flowchart, BPMN, а также Стратегических картах.
Таблица 3. Палитра элементов окна диаграммы

Контекстные меню окна диаграммы

Пункт меню Описание
Color schemes… Выбор цветовой гаммы.
Настроить показ параметровВыводит на экран окно Настройка показа параметров объекта, в котором можно выбрать параметры объекта, которые требуется выводить на диаграмму рядом с ним, а также настройки их вывода. Подробнее см. Вывод значений параметров объектов на диаграмму.
Cut Вырезать Удаляет выделенный объект с диаграммы, помещая его в буфер обмена.
Copy Копировать Помещает выделенный объект в буфер обмена.
Paste Вставить Вставляет объект из буфера обмена.
Paste Special… Специальная вставка Для MS Visio 2010 и 2013. Вставляет объект из буфера обмена в определенном формате. Формат выбирается пользователем из предлагаемого списка.
Hyperlink… Гиперссылка Для MS Visio 2010 и 2013. К любой фигуре можно добавлять гиперссылки, указывающие на веб-сайты, FTP-ресурсы, адреса электронной почты и локальные файлы.
Format Формат См. ниже.
Bring to Front → Bring to Front На передний план → На передний план Управляет взаимным расположением фигур. Перевод фигуры на верхний слой диаграммы. В версиях MS Visio 2003 и 2007 данный пункт находится в меню Фигура → На передний план.
Bring to Front → Bring Forward На передний план → Переместить вперед Управляет взаимным расположением фигур. Перевод фигуры выше на один слой диаграммы. В версиях MS Visio 2003 и 2007 данный пункт находится в меню Фигура → Переместить вперед.
Send to Back → Send to Back На задний план → На задний план Управляет взаимным расположением фигур. Перевод фигуры на нижний слой диаграммы. В версиях MS Visio 2003 и 2007 данный пункт находится в меню Фигура → На задний план.
Send to Back → Send Backward На задний план → Переместить назад Управляет взаимным расположением фигур. Перевод фигуры ниже на один слой диаграммы. В версиях MS Visio 2003 и 2007 данный пункт находится в меню Фигура → Переместить назад.
Выделить все подобные Выделение всех фигур. Если выделена какая-либо фигура, то происходит выделение всех фигур с выбранным типом. Например, при выделении стрелки "Поток объектов" будут выделены только стрелки с типом "Поток объектов".
Сменить объект Открывается окно выбора из соответствующего справочника того объекта, который будет обозначен данной фигурой.
Использование на диаграммах Открывает окно с информацией о том, на каких диаграммах используется данный объект. С помощью кнопки "Перейти" в этом окне можно открыть выбранную диаграмму.
Свойства объекта Открывается Окно свойств объекта, обозначенного при помощи выделенной фигуры.

Меню "Format (Формат)"

Пункт меню Описание
Text… Текст… Выбор шрифта текста выделенного объекта.
Line… Линия… Выбор линии стрелки, рамки выделенного объекта.
Fill… Заливка… Выбор заливки выделенного объекта.

Вывод значений параметров объектов на диаграмму

Вывод значений параметров объектов на диаграмму настраивается в окне Настройка показа параметров объекта, которое выводится на показ пунктом Настроить показ параметров контекстного меню фигуры диаграммы. Внешний вид этого окна для любых фигур диаграммы, кроме стрелок, приведен на Рисунке 2. Для стрелок диаграмм внешний вид данного окна немного отличается, но принципы работы в нем такие же, как описано ниже.

Если для фигуры диаграммы уже настроен вывод параметров, переключатель области вывода параметра при открытии окна будет установлен на первый по порядку из настроенных параметров (поиск ведется сначала по параметрам, а затем по сноскам).

Рисунок 2. Окно Настройка показа параметров объекта

В верхней части окна можно выбрать, включив соответствующий переключатель, в какую именно область относительно фигуры диаграммы нужно выводить значение параметра объекта, обозначенного данной фигурой.

С помощью полей в нижней части окна задаются другие настройки вывода параметра объекта на диаграмму.

Элемент Назначение
Область вывода параметра Задается кликом мыши в одном из предустановленных переключателей. Выбор области определяет, как будет расположен выводимый параметр относительно блока фигуры на диаграмме. В области с пометкой Сноска удобно выводить списки, а в области с пометкой Параметр - обычные параметры объекта, но данная привязка не является жесткой: можно также выводить в области с пометкой Сноска обычные параметры, а в области с пометкой Параметр - списки объекта.
Источник данных Выбор источника данных для вывода значений параметров на диаграмму. В качестве источника данных может выступать сам объект или ссылающаяся на этот объект фигура диаграммы (для некоторых типов фигур диаграмм, например, для событий).
Параметр для отображения Выбор параметра для вывода на диаграмму. Выбор осуществляется из справочника, открываемого нажатием на кнопку в данном поле. Нажатие на кнопку очищает значение поля.
Параметр списка Заполняется, если в поле Параметр для отображения выбран параметр с типом "Список". В поле выбирается объектный параметр списка.
Число выводимых строк Заполняется, если в поле Параметр для отображения выбран параметр с типом "Список". В поле задается количество строк списка, которое должно быть выведено на диаграмму.
Отображать заголовок параметра Опция управляет отображением рядом со значением параметра его заголовка.
Выравнивание Параметр-перечисление, который может принимать значения "Слева", "По центру" и "Справа". С его помощью можно задать выравнивание текста в области вывода параметра.
Префикс Последовательность символов, которая будет выводиться перед значением параметра.
Постфикс Последовательность символов, которая будет выводиться после значения параметра.
Маркер строк списка Заполняется, если в поле Параметр для отображения выбран параметр с типом "Список". Последовательность символов, которая будет выводиться в качестве маркера строк выводимого списка.
В случае, если в качестве области вывода параметра выбран "Параметр 7", заполнение этого поля недоступно.
Очистить все настройки Кнопка для очистки всех настроек в окне.
Применить ко всем фигурам данного типа Если опция включена, заданные в окне настройки применятся ко всем подобным фигурам диаграммы при нажатии на кнопку ОК. Если опция выключена - настройки применяются только к той фигуре диаграммы, от которого вызвано окно настроек.
Таблица 4. Элементы окна "Настройка показа параметров объекта"

Нажатие на кнопку OK применяет сделанные в окне изменения, нажатие на кнопку Отмена отменяет их.

Настройки, показанные выше на Рисунке 2, позволяют вывести на диаграмму для данного блока единицы деятельности список участвующих в его выполнении оргединиц (список "Оргединицы").

Захватывая мышью параметры, выведенные на диаграмму в области с пометкой "Сноска" (Рис. 3), можно перемещать их для расположения на диаграмме требуемым образом.

Рисунок 3. Блок единицы деятельности с выведенным рядом списком оргединиц

Данный способ применим для вывода параметров на диаграммы любых типов. Для диаграмм оргединиц существует еще один способ вывода параметров, с его описанием можно ознакомится в главе Параметры оргдиаграммы.

Для отображения параметров стрелки окно Настройка показа параметров объекта имеет подобный вид как на Рисунке 2 и работает аналогично.

Настройки, показанные на Рисунке 4, позволяют вывести на диаграмму процесса в нотации BPMN список статусов функционального объекта (Окно свойств объекта, обозначающего функциональный объект → вкладка Основные → вкладка Статусы) в области, обозначенной Параметром 7.

Рисунок 4. Окно Настройка показа параметров объекта с настройкой вывода на показ списка статусов элемента "Объект данных"

На Рис. 5 приведен пример вывода статуса "Подписанный" для функционального объекта "Акт выполненных работ" на диаграмме процесса в нотации BPMN.

Рисунок 5. Вывод на показ статуса функционального объекта

Команды "Undo" (Отмена) и "Redo" (Возврат)

Команда "Undo" (CTRL+Z) позволяет отменить выполнение нескольких последних шагов и вернуться к более ранней версии изображения.

Команда "Redo" (CTRL+Y) позволяет снова выполнить отмененный ранее шаг.

Внимание! Команды "Undo" (Отмена) и "Redo" (Возврат) относятся только к графическому оформлению, модификации с объектной моделью производят не полностью и в некоторых случаях могут не поддерживаться. Рекомендуется использовать их для отказа от изменений на диаграмме, не связанных с созданием, удалением, соединением фигур.

Режимы рисования диаграмм

Доступно 2 режима рисования диаграмм:

  1. По сетке. Включает показ сетки и задаёт фиксированный размер интервала сетки.
  2. Свободный. Отключает показ сетки и включает режим визуальных подсказок по размещению фигур на диаграмме.

По умолчанию включен режим "Свободный". Изменить режим рисования для каждой базы данных можно в параметре Режим рисования диаграммы в Настройках для всех пользователей. Заданный режим применяется только для новых диаграмм.

Основные различия между значениями опций настройки диаграммы для режимов рисования "По сетке" и "Свободный" приведены в Таблице 1.

Наименование опции Расположение опции Значение опции для режима "По сетке" Значение опции для режима "Свободный"
Сетка Панель инструментов Окна диаграммы → кнопка ДействияПоложение фигур + -
Динамическая сетка Окно Привязать и приклеить (Панель инструментов Окна диаграммы → кнопка ДействияПоложение фигурПривязка фигур или комбинация горячих клавиш Alt+F9) - +
Маркеры фигуры Окно Привязать и приклеить (Панель инструментов Окна диаграммы → кнопка ДействияПоложение фигурПривязка фигур или комбинация горячих клавиш Alt+F9) - +
Вспомогательные линии Окно Привязать и приклеить (Панель инструментов Окна диаграммы → кнопка ДействияПоложение фигурПривязка фигур или комбинация горячих клавиш Alt+F9) - +
Таблица 1. Основные различия между значениями опций настройки диаграммы для режимов рисования "По сетке" и "Свободный"

На основании информации из этой таблицы можно самостоятельно настроить требуемый режим рисования для диаграммы.

Добавление фигур на диаграмму перетаскиванием

Интерфейс Business Studio позволяет добавлять фигуры на диаграмму, "перетаскивая" их из Навигатора или из Окна справочника. Перетаскиванием осуществляется, например, добавление междиаграммных и внешних ссылок, добавление стрелок, добавление оргединиц на диаграмму Cross-functional Flowchart, добавление целей, показателей и перспектив на диаграмму стратегической карты.

На Рис. 6 показано добавление оргединицы перетаскиванием из Навигатора на диаграмму Cross-functional Flowchart.

Рисунок 6. Добавление оргединицы перетаскиванием из Навигатора на диаграмму Cross-functional Flowchart

Графическая трансформация фигур на диаграмме

Размеры фигуры на диаграмме можно изменять. Для этого сначала выделите фигуру нажатием мыши, затем наведите курсор мыши на одну из меток на гранях выделенной фигуры, нажмите левую кнопку мыши и, удерживая ее, перемещайте мышь, пока фигура не примет нужный размер. На Рис. 7 приведены примеры изменения размеров различных фигур (а - изменение размера цели на диаграмме стратегической карты; б - изменение размера единицы деятельности на диаграмме процесса в нотации Cross-functional Flowchart; в - изменение размера оргединицы на диаграмме процесса в нотации Cross-functional Flowchart).

Рисунок 7. Примеры изменения размеров фигур на диаграмме

Возможно также изменение размера группы фигур. Для этого необходимо выделить нужные фигуры (подробнее о работе с группой фигур диаграммы см. Работа с группой фигур диаграммы) и изменить размер общего прямоугольника.

Графическая трансформация динамических соединительных линий

Графическая трансформация динамических соединительных линий (стрелок) осуществляется перетаскиванием значков на линии выделенной стрелки и её концах. Чтобы изменить стрелку, сначала выделите ее щелчком мыши.

Способ изображения стрелки выбирается с помощью команд контекстного меню стрелки. Если стрелку необходимо выровнять по горизонтали или вертикали, удерживайте клавишу Shift и перемещайте мышью значок начала или конца стрелки.

Рисунок 8

С помощью клавиш Ctrl и Shift можно произвести специальную трансформацию средней части линии стрелки. Подведите курсор к центру выделенной стрелки так, чтобы он получил вид двунаправленной стрелки. Затем, удерживая клавишу Ctrl или Shift, нажмите на левую кнопку мыши и, удерживая ее, переместите курсор мыши. На Рис. 9 показано: а - выделение средней части стрелки; б - действие клавиши Ctrl; в - действие клавиши Shift.

Рисунок 9. Трансформация средней части линии стрелки с помощью клавиш Ctrl и Shift

Графическая трансформация кривых соединительных линий

Графическая трансформация кривых соединительных линий (стрелок) осуществляется перетаскиванием значков на линии выделенной стрелки и её концах. Чтобы изменить стрелку, сначала выделите ее нажатием мыши.

Чтобы изменить кривизну дуги стрелки, выделите желтый значок на середине стрелки, зажмите левую кнопку мыши, после этого переместите курсор мыши (Рис. 10).

Рисунок 10. Графическая трансформация кривых соединительных линий

Режим рисования стрелок

Режим рисования стрелок включается кнопкой или щелчком средней кнопкой мыши. Чтобы создать стрелку, подведите курсор к месту начала стрелки, нажмите левую кнопку мыши. Удерживая левую кнопку мыши, перетащите курсор к концу стрелки и отпустите.

В этом режиме можно работать и с другими фигурами диаграммы. Например, для перемещения фигуры наведите курсор на фигуру до принятия курсором вида , нажмите левую кнопку мыши и перетащите фигуру.

Переключение в режим выделения осуществляется щелчком средней кнопки мыши.

Соединение фигур возможно как к граням фигур (Рис. 11), так и к центру фигуры (Рис. 12).

Рисунок 11. Присоединение стрелки к грани фигуры
Рисунок 12. Присоединение стрелки к центру фигуры

В последнем случае - при выделении стрелки точки соединения показываются более крупными (Рис. 13). Если соединение произведено к центру фигуры, то при перемещении стрелка будет перемещаться относительно ее грани (Рис. 14), что удобно, на диаграммах EPC, например.

Рисунок 13
Рисунок 14

Текстовые метки на диаграмме

Текстовыми метками называются все надписи на диаграмме: стрелках, фигурах объектов, а также произвольный текст, размещенный на диаграмме.

С помощью кнопки на панели инструментов диаграммы, сочетания клавиш Ctrl+T, или двойным щелчком средней кнопки мыши включается режим работы с текстовыми метками (далее текстовый режим). Для продолжения работы с фигурами диаграммы надо выключить текстовый режим, т.е. отжать кнопку , нажать Ctrl+T или щелкнуть средней кнопкой мыши.

На Рис. 15 показано, как выглядит курсор, когда режим включен. Щелчок мышью в пустом месте диаграммы добавляет прямоугольник для ввода произвольного текста. Размеры прямоугольника можно задать самостоятельно, нажав левую кнопку мыши и перемещая курсор по диагонали воображаемого прямоугольника.

Рисунок 15, а
Рисунок 15, б
Рисунок 15, в


Положение надписи фигуры относительно его контура можно изменить. Для этого подведите курсор, находящийся в текстовом режиме к надписи фигуры (Рис. 16, а), удерживайте левую кнопку мыши и перемещайте надпись (Рис. 16, б). Двойной щелчок по надписи переводит курсор в режим редактирования текста надписи (Рис. 16, в).

Рисунок 16, а
Рисунок 16, б
Рисунок 16, в


В MS Visio 2003 и 2007 направление текста в заголовках колонок можно изменить, сделав его вертикальным (горизонтальным). Щелкните правой кнопкой мыши по полю заголовка и выберите в контекстном меню пункт Display All Band Labels Vertically (Horizontally) или Отобразить все полосы и подписи вертикально (горизонтально). На Рис. 17 расположение заголовков на диаграмме процедуры изменено на вертикальное.

Рисунок 17. Изменение направления текста в заголовках колонок диаграммы

Переименование объектов на диаграмме

При переименовании объекта какого-либо класса на диаграмме новое название может совпасть с названием, уже существующего в данном классе объекта. В этом случае на экран будет выведено окно "Переименование объекта" (см. Рис. 18), в котором будет предложено выбрать одно из действий:

  • Заменить текущий объект на существующий в справочнике – вместо переименуемого объекта на диаграмме будет использоваться одноименный существующий объект из справочника.
  • Использовать это название – в справочнике создается и используется на диаграмме новый объект с указанным названием.
Рисунок 18. Объект с таким названием уже существует

В Настройках пользователя в параметре Настройки уведомлений можно включить уведомления при переименовании объекта, используемого на нескольких диаграммах. Если попытаться переименовать объект, который используется на нескольких диаграммах, на экран будет выведено окно "Переименование объекта" с другим наполнением, чем показано на рисунке 18 выше (см. Рис. 19), в котором будет предложено выбрать одно из действий:

  • Переименовать объект - название изменится у фигур данного объекта на этой и всех остальных диаграммах.
  • Создать новый объект - будет создан новый объект и название изменится только у текущей фигуры на этой диаграмме
Рисунок 19. Объект используется на нескольких диаграммах

Если при переименовании возникнут сразу обе описанные выше ситуации, рассмотренные окна будут выведены на экран по очереди.

Копирование формата фигуры диаграммы

Формат, выбранный, например, для линии рамки одной фигуры диаграммы, можно копировать для другой фигуры при помощи комбинации клавиш Ctrl+Shift+P или кнопки Формат по образцу на панели инструментов, не открывая для каждой следующей фигуры меню Формат (Format).

Выберите в контекстном меню фигуры (например, стрелки) пункт Формат → Линия (Format → Line) или используйте комбинацию клавиш Shift+F3 и измените цвет линии рамки и её толщину. Затем выделите измененную стрелку и нажмите Ctrl+Shift+P. При этом рядом с курсором мыши появится значок кисточки. Если кликнуть курсором такого вида по другой стрелке, формат ее линии станет таким же, как у той стрелки, с которой мы его копировали.

Рисунок 20. Копирование формата фигуры диаграммы

Изменение параметров страницы диаграммы

Для изменения масштаба диаграммы и размеров страницы откройте окно Параметры страницы (панель инструментов Окна диаграммы → кнопка ДействияСтраницаПараметры страницы).

На вкладке Настройка печати (Рис. 21) указываются размеры листа бумаги и масштаб печати диаграммы. Доступный выбор зависит от типа принтера.

Рисунок 21. Вкладка Настройка печати окна Параметры страницы

С помощью опций на вкладке Размер страницы (Рис. 22) устанавливаются размеры диаграммы относительно страницы. При использовании MS Visio 2003/2007 на этой вкладке также находится флажок Изменять размер по содержимому, установка которого изменяет размеры диаграммы так, чтобы они стали равны размеру страницы. Диаграмма при этом может быть растянута по вертикали и горизонтали. При использовании MS Visio 2010 и 2013 данный флажок называется Изменить размеры по содержимому и находится в выпадающем меню кнопки Действия (панель инструментов Окна диаграммы → кнопка ДействияСтраницаИзменить размеры по содержимому).

Рисунок 22. Вкладка Размер страницы окна Параметры страницы
Практический совет

Существует возможность быстро изменить размеры страницы путём перетаскивания её краёв. Для этого:

  1. Наведите курсор мыши на край страницы (верхний или нижний) или её угол, а затем нажмите и удерживайте клавишу Ctrl - курсор примет вид двухсторонней стрелки.
  2. Зажав и удерживая левую кнопку мыши, перетащите край страницы в нужное место, после чего отпустите левую клавишу мыши - страница изменит размер соответствующим образом.

Работа с группой фигур диаграммы

Группу фигур диаграммы можно выделить двумя способами:

  1. Удерживая клавишу Shift, щелкнуть мышью по всем фигурам, которые должны войти в группу;
  2. Расположить курсор мыши в одном из углов воображаемого прямоугольника, охватывающего группу фигур. Нажать левую кнопку мыши и, удерживая кнопку, переместить курсор по диагонали прямоугольника. Затем отпустить кнопку мыши.

В обоих случаях выделяются контуры всех выбранных фигур, а также показывается рамка прямоугольника, охватывающего группу. С помощью значков на гранях прямоугольника группы можно изменить изображение фигур: растянуть их по вертикали и горизонтали, повернуть вокруг оси.

Основной фигурой в группе является та, чей контур выделен ярче контура остальных фигур. Все кнопки на панели инструментов действуют для этой основной фигуры.

Перемещение группы фигур

Для перемещения группы фигур на экране, подведите курсор к выделенной грани любой фигуры в группе так, чтобы появился значок перемещения - "перекрещенные стрелки". Затем переместите курсор на экране, удерживая нажатой левую кнопку мыши или с помощью клавиатуры.

Удаление группы фигур

Не отпуская клавишу Shift после выделения группы, щелкните правой кнопкой мыши для вызова контекстного меню. Выберите в меню пункт меню Вырезать (Cut).

Копирование группы фигур

Любые фигуры диаграммы можно копировать и вставлять в диаграмму из буфера обмена. Возможно также копирование фигур из другой диаграммы Business Studio.

Копирование осуществляется с помощью пунктов меню Копировать (Copy), Вставить (Paste) в контекстном меню фигуры диаграммы или с помощью стандартных клавиатурных комбинаций (Ctrl+Ins, Ctrl+C и Shift+Ins, Ctrl+V).

Кроме того, фигуры диаграммы можно копировать с помощью перетаскивания, удерживая нажатой клавишу Ctrl. Порядок действий при этом должен быть таким: сначала удерживается нажатой клавиша Ctrl, затем выделяется и перетаскивается мышью фигура диаграммы. Особенно важен этот порядок действий для копирования фигуры диаграммы "стрелка", так как клавиша Ctrl используется также и для графической трансформации стрелки (см. Графическая трансформация кривых соединительных линий).

С помощью клавиши Ctrl можно копировать группу, состоящую из любых фигур диаграммы. Порядок действий при этом должен быть следующим:

  1. Выделите группу фигур.
    Рисунок 23
  2. Затем, отпустите клавишу Shift и нажмите клавишу Ctrl. Подведите курсор к границе любой выделенной фигуры так, чтобы большой "крестик" курсора перемещения превратился в маленький "крестик" рядом с курсором мыши.
    Рисунок 24
  3. Продолжая удерживать клавишу Ctrl, перетащите группу фигур в нужное место на странице и отпустите кнопку мыши. При этом курсор мыши должен перейти в состояние ожидания. Отпустите клавишу Ctrl только после того, как курсор мыши вернется в обычное состояние. Теперь выделенной станет новая группа фигур. Щелкните в любом месте страницы, чтобы погасить выделение фигур.
    Рисунок 25

Выравнивание фигур

С помощью пункта меню Выравнивание фигур (панель инструментов Окна диаграммы → кнопка ДействияПоложение фигур) открывается окно Выравнивание фигур (Рис. 26), в котором выбирается вид выравнивания. Выравниваются две и более выделенных фигур.

Рисунок 26. Окно Выравнивание фигур

Возможно вертикальное и горизонтальное выравнивание по заданной оси. Кнопка , расположенная справа от кнопок выравнивания, служит для отказа от сделанного выбора.

Выбранную ось выравнивания можно сохранить вместе с диаграммой и использовать в дальнейшем для перемещения группы фигур. Для этого служит флажок Создать направляющую и приклеить к ней фигуры (Создать ось и выравнивать элементы по ней), который становится активным после выбора вида выравнивания.

Созданная ось выравнивания будет показана на диаграмме (Рис. 27). Чтобы перетащить группу фигур, надо щелкнуть по оси и перетащить её. Связь фигур с осью необязательна. Каждый из фигур этой группы можно перемещать на диаграмме произвольно. Фигуры, оставшиеся на оси, можно перетаскивать осью.

Рисунок 27. Ось выравнивания

Когда ось станет не нужна, удалите её с диаграммы с помощью команды контекстного меню Вырезать (Cut) или клавишей Del.

Распределение фигур

С помощью пункта меню Распределение фигур (панель инструментов Окна диаграммы → кнопка ДействияПоложение фигур) производится распределение фигур. Распределить можно три и более выделенных фигуры. В окне Распределение фигур (Рис. 28) выбирается вариант распределения фигур по заданным осям.

Рисунок 28. Окно Распределение фигур

Работают оси распределения так же, как и ось выравнивания. Их можно сохранить с диаграммой и использовать в дальнейшем для перемещения группы фигур.

Флажок Создать направляющие и приклеить к ним фигуры становится активным после выбора варианта распределения. Перемещение группы фигур осуществляется перетаскиванием одной из осей (Рис. 29).

Рисунок 29. Перемещение группы фигур перетаскиванием одной из осей распределения
« ПредыдущаяНа уровень вышеСледующая »
Driven by DokuWiki