Окно диаграммы

Окно диаграммы предназначено для создания и редактирования диаграмм процессов, организационных диаграмм, диаграмм стратегических карт и диаграмм Исикавы (Рис. 1).

Рисунок 1. Окно диаграммы


Окно диаграммы открывается двойным щелчком по названию объекта, для которого может быть построена диаграмма, в Навигаторе или щелчком по кнопке на панели инструментов Навигатора.

Практический совет

Навигатор и Окно диаграммы всегда одновременно открыты в Главном окне программы. Разделяющая их подвижная граница дает возможность изменять их размеры относительно друг друга. Если для работы с диаграммой требуется вся рабочая область Главного окна, то окно Навигатора можно свернуть, нажав на кнопку Скрывать автоматически в заголовке Навигатора.


Сверху расположена панель инструментов. Работа с инструментами происходит нажатием на кнопки панели. Слева расположена палитра элементов, набор элементов которой зависит от типа редактируемой диаграммы. Работа с элементами на палитре возможна нажатием их кнопок или переносом элемента на диаграмму. При нажатии на элемент осуществляется добавление в центр текущей диаграммы (может использоваться для быстрого добавления сразу нескольких элементов). При нажатии на элемент "Рамка" осуществляется добавление рамки на диаграмму и размещение ее по границам рабочей области диаграммы с учетом отступа рамки, заданного в Настройках пользователя в параметре "Настройка диаграмм" (Главное меню → Главная → Настройки пользователя → вкладка Основные). При необходимости размеры рамки можно изменять. Для того чтобы разместить рамку по границам рабочей области диаграммы с учетом отступа рамки, можно воспользоваться пунктом контекстного меню рамки Центрировать рамку.

Описание назначения кнопок панели инструментов Окна диаграммы приведено в Таблице 1:

Кнопка Назначение
Свойства объекта (Ctrl+E). Открывает Окно свойств объекта, обозначенного данным элементом диаграммы. В случае, если элемент принадлежит диаграмме, Окно свойств объекта открывается без возможности сохранения произведенных изменений, в отличие от того же окна, открываемого для объекта из Навигатора (см. Работа в окне свойств объекта). Изменения свойств объектов, диаграммы сохраняются при сохранении всей диаграммы в целом.
Сохранение диаграммы (Ctrl+S). Сохраняется текущая диаграмма, то есть все её элементы и сделанные в них изменения. При работе с диаграммами процессов изменения, которые в них делаются, сразу отражаются в дереве объектов (например, добавляется процесс или действие). Несмотря на это, при отказе от сохранения изменений на диаграмме, в дереве все элементы также останутся без изменений (т.е. не будет добавлен новый процесс или действие). Если во время редактирования диаграммы в дереве изменяются другие элементы, не имеющие отношения к текущей диаграмме, то эти элементы сохраняются сразу автоматически. При работе с другими типами диаграмм изменения и производимые с элементами действия (добавление элементов на диаграмму, создание связей между элементами) сохраняются в момент сохранения диаграммы. Если произведенные на диаграмме изменения не были сохранены, то при смене или закрытии диаграммы выдается запрос о подтверждении сохранения изменений при отключенной опции "Автосохранение диаграмм" в Настройках пользователя (Главное менюГлавнаяНастройки пользователя → вкладка Основные).
Работа с текстовыми метками (Ctrl+Т, двойной щелчок средней кнопкой мыши). Состояние включено/выключено (кнопка нажата/отжата). Во включенном состоянии позволяет добавить на диаграмму произвольный текст, а также изменить надпись элемента и положение надписи относительно элемента. (Для управления с помощью мыши функция средней кнопки должна быть установлена в Middle Button в панели управления мышью Windows.)
Формат по образцу (Ctrl+Shift+P). Копирует формат выделенного элемента. Подробнее см. Копирование формата элемента диаграммы.
Предыдущая диаграмма. Осуществляется переход к предыдущей открытой диаграмме, сохраняется история перемещений до закрытия Окна диаграммы.
Следующая диаграмма. Осуществляется переход к следующей открытой диаграмме, сохраняется история перемещений до закрытия Окна диаграммы. Кнопка активируется, если был переход к предыдущей открытой диаграмме.
Управление масштабом диаграммы.
Масштаб по умолчанию. Если кнопка нажата - открытие диаграммы осуществляется в том масштабе, который выбран в выпадающем списке масштабов. Удобно для просмотра большого количества диаграмм. Если кнопка отжата - диаграммы открываются с сохраненным масштабом.
Таблица 1. Панель инструментов окна диаграммы

Описание назначения пунктов выпадающего меню кнопки Действия приведено в Таблице 2.

Пункт меню Назначение
Обновить Отказ от всех изменений. Диаграмма загружается заново, все произведенные изменения теряются.
Передать диаграмму в Visio Открывает окно Microsoft Visio, в котором диаграмму можно сохранять, корректировать, распечатать, отправить по почте. Это однонаправленная операция: изменения, сделанные в Microsoft Visio, не переносятся в Business Studio.
Предварительный просмотр Открывает диаграмму в MS Visio в режиме предварительного просмотра для последующей печати.
Печать Открывает окно Печать для редактирования параметров вывода на печать.
Страница → Параметры страницы Открывает окно Параметры страницы для редактирования параметров страницы текущей диаграммы.
Страница → Изменить размеры по содержимому Для MS Visio 2010 и 2013. Установка флажка для пункта меню Изменить размер по содержимому изменяет размеры диаграммы так, чтобы она занимала все доступное пространство страницы (см. Изменение параметров страницы диаграммы).
Страница → Сетка Флажок отображением сетки на диаграмме.
Страница → Параметры сетки Открывает окно Линейка и сетка с настройками сетки страницы. Все процессы на диаграмме, создаваемые автоматически, выровнены по сетке.
Страница → Разрывы страниц Включает отображение на диаграмме разрывов страниц. Это позволяет посмотреть, что будет напечатано на каждой странице документа.
Дополнительно → Панорама и масштаб Открывает панель Панорама и масштаб для масштабирования страницы с диаграммой в рабочей области Окна диаграммы.
Дополнительно → Масштаб Открывает окно с настройкой масштаба.
Дополнительно → Размер и положение Открывает панель Размер и положение, показывающую координаты выбранного элемента. Удобно для точного позиционирования элементов.
Положение фигур → Выравнивание фигур (F8) Работает с двумя и более выделенными элементами. В окне Выравнивание фигур выбирается вид выравнивания элементов.
Положение фигур → Распределение фигур Работает с тремя и более выделенными элементами. В окне Распределение фигур выбирается вариант распределения элементов.
Положение фигур → Привязка фигур (Alt+F9) Открывает окно Привязать и приклеить с настройкой привязок. Здесь можно настроить способ "приклеивания" элементов друг к другу и выравнивания элементов по сетке.
Стили Работа со стилями диаграммы. Подробнее см. Стили диаграмм.
Таблица 2. Пункты выпадающего меню кнопки "Действия"

Контекстные меню окна диаграммы

Пункт меню Описание
Color schemes… Выбор цветовой гаммы.
Настроить показ параметровВыводит на экран окно Настройка текстовых меток элемента, в котором можно выбрать параметры элемента, которые требуется выводить на диаграмму рядом с ним, а также настройки их вывода. Подробнее см. Вывод значений параметров объектов на диаграмму.
Cut Вырезать Удаляет выделенный объект с диаграммы, помещая его в буфер обмена.
Copy Копировать Помещает выделенный объект в буфер обмена.
Paste Вставить Вставляет объект из буфера обмена.
Paste Special… Специальная вставка Для MS Visio 2010 и 2013. Вставляет объект из буфера обмена в определенном формате. Формат выбирается пользователем из предлагаемого списка.
Hyperlink… Гиперссылка Для MS Visio 2010 и 2013. К любой фигуре можно добавлять гиперссылки, указывающие на веб-сайты, FTP-ресурсы, адреса электронной почты и локальные файлы.
Format Формат См. ниже.
Bring to Front → Bring to Front На передний план → На передний план Управляет взаимным расположением фигур. Перевод фигуры на верхний слой диаграммы. В версиях MS Visio 2003 и 2007 данный пункт находится в меню Фигура → На передний план.
Bring to Front → Bring Forward На передний план → Переместить вперед Управляет взаимным расположением фигур. Перевод фигуры выше на один слой диаграммы. В версиях MS Visio 2003 и 2007 данный пункт находится в меню Фигура → Переместить вперед.
Send to Back → Send to Back На задний план → На задний план Управляет взаимным расположением фигур. Перевод фигуры на нижний слой диаграммы. В версиях MS Visio 2003 и 2007 данный пункт находится в меню Фигура → На задний план.
Send to Back → Send Backward На задний план → Переместить назад Управляет взаимным расположением фигур. Перевод фигуры ниже на один слой диаграммы. В версиях MS Visio 2003 и 2007 данный пункт находится в меню Фигура → Переместить назад.
Выделить все Выделение всех элементов. Если выделен какой-либо элемент, то происходит выделение всех элементов с выбранным типом. Например, при выделении стрелки "Поток объектов" будут выделены только стрелки с типом "Поток объектов".
Сменить объект Открывается окно выбора из соответствующего справочника того объекта, который будет обозначен данным элементом.
Использование на диаграммах Открывает окно с информацией о том, на каких диаграммах используется данный объект. С помощью кнопки "Перейти" в этом окне можно открыть выбранную диаграмму.
Свойства объекта Открывается Окно свойств объекта, обозначенного при помощи выделенного элемента.

Меню "Format (Формат)"

Пункт меню Описание
Text… Текст… Выбор шрифта текста выделенного объекта.
Line… Линия… Выбор линии стрелки, рамки выделенного объекта.
Fill… Заливка… Выбор заливки выделенного объекта.

Вывод значений параметров объектов на диаграмму

Вывод значений параметров объектов на диаграмму настраивается в окне Настройка текстовых меток элемента (Рис. 2), которое выводится на показ пунктом Настроить показ параметров контекстного меню элемента диаграммы. Если для элемента диаграммы уже настроен вывод параметров, переключатель области вывода параметра при открытии окна будет установлен на первый по порядку из настроенных параметров (поиск ведется сначала по параметрам, а затем по сноскам).

Рисунок 2. Окно Настройка текстовых меток элемента

В верхней части окна можно выбрать, включив соответствующий переключатель, в какую именно область относительно элемента диаграммы нужно выводить значение параметра объекта, обозначенного данным элементом.

С помощью полей в нижней части окна задаются другие настройки вывода параметра объекта на диаграмму.

Элемент Назначение
Область вывода параметра Задается кликом мыши в одном из предустановленных переключателей. Выбор области определяет, как будет расположен выводимый параметр относительно блока элемента на диаграмме. В области с пометкой Сноска удобно выводить списки, а в области с пометкой Параметр - обычные параметры объекта, но данная привязка не является жесткой: можно также выводить в области с пометкой Сноска обычные параметры, а в области с пометкой Параметр - списки объекта.
Источник данных Выбор источника данных для вывода значений параметров на диаграмму. В качестве источника данных может выступать сам объект или ссылающийся на этот объект элемент диаграммы (для некоторых типов элементов диаграмм, например, для событий).
Параметр для отображения Выбор параметра для вывода на диаграмму. Выбор осуществляется из справочника, открываемого нажатием на кнопку в данном поле. Нажатие на кнопку очищает значение поля.
Параметр списка Заполняется, если в поле Параметр для отображения выбран параметр с типом "Список". В поле выбирается объектный параметр списка.
Число выводимых строк Заполняется, если в поле Параметр для отображения выбран параметр с типом "Список". В поле задается количество строк списка, которое должно быть выведено на диаграмму.
Отображать заголовок параметра Опция управляет отображением рядом со значением параметра его заголовка.
Выравнивание Параметр-перечисление, который может принимать значения "Слева", "По центру" и "Справа". С его помощью можно задать выравнивание текста в области вывода параметра.
Префикс Последовательность символов, которая будет выводиться перед значением параметра.
Постфикс Последовательность символов, которая будет выводиться после значения параметра.
Маркер строк списка Заполняется, если в поле Параметр для отображения выбран параметр с типом "Список". Последовательность символов, которая будет выводиться в качестве маркера строк выводимого списка.
В случае, если в качестве области вывода параметра выбран "Параметр 7", заполнение этого поля недоступно.
Очистить все настройки Кнопка для очистки всех настроек в окне.
Применить ко всем подобным элементам диаграммы Если опция включена, заданные в окне настройки применятся ко всем подобным элементам диаграммы при нажатии на кнопку ОК. Если опция выключена - настройки применяются только к тому элементу диаграммы, от которого вызвано окно настроек.
Таблица 3. Элементы окна "Настройка текстовых меток элемента"

Нажатие на кнопку OK применяет сделанные в окне изменения, нажатие на кнопку Отмена отменяет их.

Настройки, показанные выше на Рисунке 2, позволяют вывести на диаграмму для данного блока процессов список участвующих в его выполнении субъектов (список "Субъекты").

Захватывая мышью параметры, выведенные на диаграмму в области с пометкой "Сноска" (Рис. 3), можно перемещать их для расположения на диаграмме требуемым образом.

Рисунок 3. Блок процесса с выведенным рядом списком субъектов

Данный способ применим для вывода параметров на диаграммы любых типов. Для диаграмм субъектов существует еще один способ вывода параметров, с его описанием можно ознакомится в главе Параметры оргдиаграммы.

Настройки, показанные на Рисунке 4, позволяют вывести на диаграмму процесса в нотации BPMN список статусов объекта деятельности (Окно свойств элемента, обозначающего объект деятельности → вкладка Основные → вкладка Статусы) в области, обозначенной Параметром 7.

Рисунок 4. Окно Настройка текстовых меток элемента с настройкой вывода на показ списка статусов элемента "Объект данных"

На Рис. 5 приведен пример вывода статуса "Подписанный" для объекта деятельности "Акт выполненных работ" на диаграмме процесса в нотации BPMN.

Рисунок 5. Вывод на показ статуса объекта деятельности

Команды "Undo" (Отмена) и "Redo" (Возврат)

Команда "Undo" (CTRL+Z) позволяет отменить выполнение нескольких последних шагов и вернуться к более ранней версии изображения.

Команда "Redo" (CTRL+Y) позволяет снова выполнить отмененный ранее шаг.

Внимание!

Команды "Undo" (Отмена) и "Redo" (Возврат) относятся только к графическому оформлению, модификации с объектной моделью производят не полностью. Рекомендуется использовать их для отказа от изменений графических действий, не связанных с созданием, удалением, соединением элементов.

Режимы рисования диаграмм

Доступно 2 режима рисования диаграмм:

  1. По сетке. Включает показ сетки и задаёт фиксированный размер интервала сетки.
  2. Свободный. Отключает показ сетки и включает режим визуальных подсказок по размещению фигур на диаграмме.

По умолчанию включен режим "Свободный". Изменить режим рисования для каждой базы данных можно в параметре "Режим рисования диаграмм" в Настройках для всех пользователей (Главное меню → Главная → Настройки для всех пользователей → вкладка Модели). Заданный режим применяется только для новых диаграмм.

Основные различия между значениями опций настройки диаграммы для режимов рисования "По сетке" и "Свободный" приведены в Таблице 1.

Наименование опции Расположение опции Значение опции для режима "По сетке" Значение опции для режима "Свободный"
Сетка Панель инструментов Окна диаграммы → кнопка ДействияПоложение фигур + -
Динамическая сетка Окно Привязать и приклеить (Панель инструментов Окна диаграммы → кнопка ДействияПоложение фигурПривязка фигур или комбинация горячих клавиш Alt+F9) - +
Маркеры фигуры Окно Привязать и приклеить (Панель инструментов Окна диаграммы → кнопка ДействияПоложение фигурПривязка фигур или комбинация горячих клавиш Alt+F9) - +
Вспомогательные линии Окно Привязать и приклеить (Панель инструментов Окна диаграммы → кнопка ДействияПоложение фигурПривязка фигур или комбинация горячих клавиш Alt+F9) - +
Таблица 1. Основные различия между значениями опций настройки диаграммы для режимов рисования "По сетке" и "Свободный"

На основании информации из этой таблицы можно самостоятельно настроить требуемый режим рисования для диаграммы.

Добавление элементов на диаграмму перетаскиванием

Интерфейс Business Studio позволяет добавлять элементы на диаграмму, "перетаскивая" их из Навигатора или из Окна справочника. Перетаскиванием осуществляется, например, добавление междиаграммных и внешних ссылок, добавление стрелок, добавление субъектов на диаграмму Процедуры, добавление целей, показателей и перспектив на диаграмму стратегической карты.

На Рис. 6 показано добавление субъекта перетаскиванием из Навигатора на диаграмму Процедуры.

Рисунок 6. Добавление субъекта перетаскиванием из Навигатора на диаграмму Процедуры

Графическая трансформация элементов на диаграмме

Размеры элемента на диаграмме можно изменять. Для этого сначала выделите элемент нажатием мыши, затем наведите курсор мыши на одну из меток на гранях выделенного элемента, нажмите левую кнопку мыши и, удерживая ее, перемещайте мышь, пока элемент не примет нужный размер. На Рис. 7 приведены примеры изменения размеров различных объектов (а - изменение размера цели на диаграмме стратегической карты; б - изменение размера процесса на диаграмме процесса в нотации Процесс; в - изменение размера субъекта на диаграмме процесса в нотации Процедура).

Рисунок 7. Примеры изменения размеров элементов на диаграмме

Возможно также изменение размера группы элементов. Для этого необходимо выделить нужные элементы (подробнее о работе с группой элементов диаграммы см. Работа с группой элементов диаграммы) и изменить размер общего прямоугольника.

Графическая трансформация динамических соединительных линий

Графическая трансформация динамических соединительных линий (стрелок) осуществляется перетаскиванием значков на линии выделенной стрелки и её концах. Чтобы изменить стрелку, сначала выделите ее щелчком мыши.

Способ изображения стрелки выбирается с помощью команд контекстного меню стрелки. Если стрелку необходимо выровнять по горизонтали или вертикали, удерживайте клавишу Shift и перемещайте мышью значок начала или конца стрелки.

Рисунок 8

С помощью клавиш Ctrl и Shift можно произвести специальную трансформацию средней части линии стрелки. Подведите курсор к центру выделенной стрелки так, чтобы он получил вид двунаправленной стрелки. Затем, удерживая клавишу Ctrl или Shift, нажмите на левую кнопку мыши и, удерживая ее, переместите курсор мыши. На Рис. 9 показано: а - выделение средней части стрелки; б - действие клавиши Ctrl; в - действие клавиши Shift.

Рисунок 9. Трансформация средней части линии стрелки с помощью клавиш Ctrl и Shift

Графическая трансформация кривых соединительных линий

Графическая трансформация кривых соединительных линий (стрелок) осуществляется перетаскиванием значков на линии выделенной стрелки и её концах. Чтобы изменить стрелку, сначала выделите ее нажатием мыши.

Чтобы изменить кривизну дуги стрелки, выделите желтый значок на середине стрелки, зажмите левую кнопку мыши, после этого переместите курсор мыши (Рис. 10).

Рисунок 10. Графическая трансформация кривых соединительных линий

Режим рисования стрелок

Режим рисования стрелок включается кнопкой или щелчком средней кнопкой мыши. Чтобы создать стрелку, подведите курсор к месту начала стрелки, нажмите левую кнопку мыши. Удерживая левую кнопку мыши, перетащите курсор к концу стрелки и отпустите.

В этом режиме можно работать и с другими элементами диаграммы. Например, для перемещения элемента подведите курсор к внешней части элемента до принятия курсором вида , нажмите левую кнопку мыши и перетащите элемент.

Переключение в режим выделения осуществляется щелчком средней кнопки мыши.

Соединение элементов возможно как к граням фигур (Рис. 11), так и к центру фигуры (Рис. 12).

Рисунок 11. Присоединение стрелки к грани фигуры
Рисунок 12. Присоединение стрелки к центру фигуры

В последнем случае - при выделении стрелки точки соединения показываются более крупными (Рис. 13). Если соединение произведено к центру фигуры, то при перемещении стрелка будет перемещаться относительно ее грани (Рис. 14), что удобно, на диаграммах EPC, например.

Рисунок 13
Рисунок 14

Текстовые метки на диаграмме

Текстовыми метками называются все надписи на элементах диаграммы: стрелках, фигурах объектов, а также произвольный текст, размещенный на диаграмме.

С помощью кнопки на панели инструментов диаграммы, сочетания клавиш Ctrl+T, или двойным щелчком средней кнопки мыши включается режим работы с текстовыми метками (далее текстовый режим). Для продолжения работы с элементами диаграммы надо выключить текстовый режим, т.е. отжать кнопку , нажать Ctrl+T или щелкнуть средней кнопкой мыши.

На Рис. 15 показано, как выглядит курсор, когда режим включен. Щелчок мышью в пустом месте диаграммы добавляет прямоугольник для ввода произвольного текста. Размеры прямоугольника можно задать самостоятельно, нажав левую кнопку мыши и перемещая курсор по диагонали воображаемого прямоугольника.

Рисунок 15, а
Рисунок 15, б
Рисунок 15, в


Положение надписи элемента относительно его контура можно изменить. Для этого подведите курсор, находящийся в текстовом режиме к надписи элемента (Рис. 16, а), удерживайте левую кнопку мыши и перемещайте надпись (Рис. 16, б). Двойной щелчок по надписи переводит курсор в режим редактирования текста надписи (Рис. 16, в).

Рисунок 16, а
Рисунок 16, б
Рисунок 16, в


В MS Visio 2003 и 2007 направление текста в заголовках колонок можно изменить, сделав его вертикальным (горизонтальным). Щелкните правой кнопкой мыши по полю заголовка и выберите в контекстном меню пункт Display All Band Labels Vertically (Horizontally) или Отобразить все полосы и подписи вертикально (горизонтально). На Рис. 17 расположение заголовков на диаграмме процедуры изменено на вертикальное.

Рисунок 17. Изменение направления текста в заголовках колонок диаграммы

Копирование формата элемента диаграммы

Формат, выбранный, например, для линии рамки одного элемента диаграммы, можно копировать для другого элемента при помощи комбинации клавиш Ctrl+Shift+P или кнопки Формат по образцу на панели инструментов, не открывая для каждого следующего элемента меню Формат (Format).

Выберите в контекстном меню элемента (например, стрелки) пункт Формат → Линия (Format → Line) или используйте комбинацию клавиш Shift+F3 и измените цвет линии рамки и её толщину. Затем выделите измененную стрелку и нажмите Ctrl+Shift+P. При этом рядом с курсором мыши появится значок кисточки. Если кликнуть курсором такого вида по другой стрелке, формат ее линии станет таким же, как у той стрелки, с которой мы его копировали.

Рисунок 18. Копирование формата элемента диаграммы

Изменение параметров страницы диаграммы

Для изменения масштаба диаграммы и размеров страницы откройте окно Параметры страницы (панель инструментов Окна диаграммы → кнопка ДействияСтраницаПараметры страницы).

На вкладке Настройка печати (Рис. 19) указываются размеры листа бумаги и масштаб печати диаграммы. Доступный выбор зависит от типа принтера.

Рисунок 19. Вкладка Настройка печати окна Параметры страницы

С помощью опций на вкладке Размер страницы (Рис. 20) устанавливаются размеры диаграммы относительно страницы. При использовании MS Visio 2003/2007 на этой вкладке также находится флажок Изменять размер по содержимому, установка которого изменяет размеры диаграммы так, чтобы они стали равны размеру страницы. Диаграмма при этом может быть растянута по вертикали и горизонтали. При использовании MS Visio 2010 и 2013 данный флажок называется Изменить размеры по содержимому и находится в выпадающем меню кнопки Действия (панель инструментов Окна диаграммы → кнопка ДействияСтраницаИзменить размеры по содержимому).

Рисунок 20. Вкладка Размер страницы окна Параметры страницы
Практический совет

Существует возможность быстро изменить размеры страницы путём перетаскивания её краёв. Для этого:

  1. Наведите курсор мыши на край страницы (верхний или нижний) или её угол, а затем нажмите и удерживайте клавишу Ctrl - курсор примет вид двухсторонней стрелки.
  2. Зажав и удерживая левую кнопку мыши, перетащите край страницы в нужное место, после чего отпустите левую клавишу мыши - страница изменит размер соответствующим образом.

Работа с группой элементов диаграммы

Группу элементов диаграммы можно выделить двумя способами:

  1. удерживая клавишу Shift, щелкнуть мышью по всем элементам, которые должны войти в группу;
  2. расположить курсор мыши в одном из углов воображаемого прямоугольника, охватывающего группу элементов. Нажать левую кнопку мыши и, удерживая кнопку, переместить курсор по диагонали прямоугольника. Затем отпустить кнопку мыши.

В обоих случаях выделяются контуры всех выбранных элементов, а также показывается рамка прямоугольника, охватывающего группу. С помощью значков на гранях прямоугольника группы можно изменить изображение элементов: растянуть их по вертикали и горизонтали, повернуть вокруг оси.

Основным элементом в группе является тот, чей контур выделен ярче контура остальных элементов. Все кнопки на панели инструментов действуют для этого основного элемента.

Перемещение группы элементов

Для перемещения группы элементов на экране, подведите курсор к выделенной грани любого элемента в группе так, чтобы появился значок перемещения - "перекрещенные стрелки". Затем переместите курсор на экране, удерживая нажатой левую кнопку мыши или с помощью клавиатуры.

Удаление группы элементов

Не отпуская клавишу Shift после выделения группы, щелкните правой кнопкой мыши для вызова контекстного меню. Выберите в меню пункт меню Вырезать (Cut).

Копирование группы элементов

Любые элементы диаграммы можно копировать и вставлять в диаграмму из буфера обмена. Возможно также копирование элементов из другой диаграммы Business Studio.

Копирование осуществляется с помощью пунктов меню Копировать (Copy), Вставить (Paste) в контекстном меню элемента диаграммы или с помощью стандартных клавиатурных комбинаций (Ctrl+Ins, Ctrl+C и Shift+Ins, Ctrl+V).

Кроме того, элементы диаграммы можно копировать с помощью перетаскивания, удерживая нажатой клавишу Ctrl. Порядок действий при этом должен быть таким: сначала удерживается нажатой клавиша Ctrl, затем выделяется и перетаскивается мышью элемент диаграммы. Особенно важен этот порядок действий для копирования элемента диаграммы "стрелка", так как клавиша Ctrl используется также и для графической трансформации стрелки (см. Графическая трансформация кривых соединительных линий).

С помощью клавиши Ctrl можно копировать группу, состоящую из любых элементов диаграммы. Порядок действий при этом должен быть следующим:

1). Выделите группу элементов.

Рисунок 21

2). Затем, отпустите клавишу Shift и нажмите клавишу Ctrl. Подведите курсор к границе любого выделенного элемента так, чтобы большой "крестик" курсора перемещения превратился в маленький "крестик" рядом с курсором мыши.

Рисунок 22

3). Продолжая удерживать клавишу Ctrl, перетащите группу элементов в нужное место на странице и отпустите кнопку мыши. При этом курсор мыши должен перейти в состояние ожидания. Отпустите клавишу Ctrl только после того, как курсор мыши вернется в обычное состояние. Теперь выделенной станет новая группа элементов. Щелкните в любом месте страницы, чтобы погасить выделение элементов.

Рисунок 23

Выравнивание фигур

С помощью пункта меню Выравнивание фигур (панель инструментов Окна диаграммы → кнопка ДействияПоложение фигур) открывается окно Выравнивание фигур (Рис. 24), в котором выбирается вид выравнивания. Выравниваются два и более выделенных элемента.

Рисунок 24. Окно Выравнивание фигур

Возможно вертикальное и горизонтальное выравнивание по заданной оси. Кнопка , расположенная справа от кнопок выравнивания, служит для отказа от сделанного выбора.

Выбранную ось выравнивания можно сохранить вместе с диаграммой и использовать в дальнейшем для перемещения группы элементов. Для этого служит флажок Создать направляющую и приклеить к ней фигуры (Создать ось и выравнивать элементы по ней), который становится активным после выбора вида выравнивания.

Созданная ось выравнивания будет показана на диаграмме (Рис. 25). Чтобы перетащить группу элементов, надо щелкнуть по оси и перетащить её. Связь элементов с осью необязательна. Каждый из элементов этой группы можно перемещать на диаграмме произвольно. Элементы, оставшиеся на оси, можно перетаскивать осью.

Рисунок 25. Ось выравнивания

Когда ось станет не нужна, удалите её с диаграммы с помощью команды контекстного меню Вырезать (Cut) или клавишей Del.

Распределение фигур

С помощью пункта меню Распределение фигур (панель инструментов Окна диаграммы → кнопка ДействияПоложение фигур) производится распределение элементов. Распределить можно три и более выделенных элемента. В окне Распределение фигур (Рис. 26) выбирается вариант распределения элементов по заданным осям.

Рисунок 26. Окно Распределение фигур

Работают оси распределения так же, как и ось выравнивания. Их можно сохранить с диаграммой и использовать в дальнейшем для перемещения группы элементов.

Флажок Создать направляющие и приклеить к ним фигуры становится активным после выбора варианта распределения. Перемещение группы элементов осуществляется перетаскиванием одной из осей (Рис. 27).

Рисунок 27. Перемещение группы элементов перетаскиванием одной из осей распределения
« ПредыдущаяНа уровень вышеСледующая »
Актуальные новости, публикации и практики для бизнес-архитекторов и аналитиков
Driven by DokuWiki